Kamis, 09 Juli 2009

Konfigurasi DHCP dan NAT

Konfigurasi Activity 7.4.2:
"Challenge DHCP and NAT"


pengaturan Router ISP

Router>enable
Router#config
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname ISP
ISP(config)#interface serial 0/0/1
ISP(config-if)#ip address 209.165.201.2 255.255.255.252
ISP(config-if)#ip route 209.165.201.0 255.255.255.252 209.165.201.1


Pengaturan Router R1

Router>enable
Router#config
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface serial 0/0/0
R1(config-if)#ip address 172.16.0.1 255.255.255.252
R1(config-if)#interface fastethernet 0/0
R1(config-if)#ip address 172.16.10.1 255.255.255.0
R1(config-if)#interface fastethernet 0/1
R1(config-if)#ip address 172.16.11.1 255.255.255.0
R1(config-if)#exit

R1(config)#router rip
R1(config-router)#network 172.16.0.0
R1(config-router)#version 2
R1(config-router)#exit

//Pengaturan DHCP//

R1(config)#interface fastethernet 0/0
R1(config-if)#ip dhcp excluded-address 172.16.10.1 172.16.10.3
R1(config)#interface fastethernet 0/1
R1(config-if)#ip dhcp excluded-address 172.16.11.1 172.16.11.3
R1(config)#interface fastethernet 0/0
R1(config-if)#ip dhcp pool R1_LAN10
R1(dhcp-config)#network 172.16.10.0 255.255.255.0
R1(dhcp-config)#default-router 172.16.10.1
R1(dhcp-config)#dns-server 172.16.20.254
R1(dhcp-config)#exit
R1(config)#interface fastethernet 0/1
R1(config-if)#ip dhcp pool R1_LAN11
R1(dhcp-config)#network 172.16.11.0 255.255.255.0
R1(dhcp-config)#default-router 172.16.11.1
R1(dhcp-config)#dns-server 172.16.20.254
R1(dhcp-config)#

Pengaturan Router R2

Router>enable
Router#config
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface serial 0/0/0
R2(config-if)#ip address 172.16.0.2 255.255.255.252
R2(config-if)#interface serial 0/0/1
R2(config-if)#ip address 209.165.201.1 255.255.255.252
R2(config-if)#interface fastethernet 0/0
R2(config-if)#ip address 172.16.20.1 255.255.255.0
R2(config-if)#exit
R2(config)#ip route 0.0.0.0 0.0.0.0 209.165.201.2

R2(config)#router rip
R2(config-router)#network 172.16.0.0
R2(config-router)#default-information originate
R2(config-router)#version 2
R2(config-router)#exit

//Pengaturan NAT//

R2(config)#ip access-list standard NAT_ACL
R2(config-std-nacl)#permit 172.16.10.0 0.0.0.255
R2(config-std-nacl)#permit 172.16.11.0 0.0.0.255
R2(config-std-nacl)#exit
R2(config)#ip nat inside source static 172.16.20.254 209.165.201.30
R2(config)#ip nat pool NAT_POOL 209.165.201.128 209.165.201.130 netmask 255.255.255.252
R2(config)#ip nat inside source list NAT_ACL pool NAT_POOL overload
R2(config)#interface fastethernet 0/0
R2(config-if)#ip nat inside
R2(config-if)#interface serial 0/0/0
R2(config-if)#ip nat inside
R2(config-if)#interface serial 0/0/1
R2(config-if)#ip nat outside
R2(config-if)#exit

0 komentar:

Posting Komentar